Web-OPAC – Fehlermeldung bei Passwort vergessen

Ich setze gerade einen WebOPAC des Herstellers BOND (Bibliotheksysteme) unter Windows Server 2012R2 auf. Die Installationsanleitung ist meiner Meinung nach schon sehr speziell geschrieben. Bevor man einen Schritt eines Abschnitts überhaupt ausführt, Anleitung einmal komplett zu Ende lesen. Denn Anmerkungen/Hinweise werden erst am Ende des jeweiligen Abschnitts niedergeschrieben.

Die Installation war nach einem Tag erledigt. Es handelt sich um eine virtuelle Maschine (Microsoft Windows Server 2012R2) in der DMZ.

Beim Testen viel auf, dass die „Passwort vergessen“ – Funktion folgende Fehlermeldung ausgibt, nachdem die Ausweisnummer eingegeben wurde (Bitte bei der Eingabe an die führenden Nullen denken):
webopac-smtp-mail

Solch nichtssagende Fehlermeldungen Liebe ich über alles. Danke an dieser Stelle an den Hersteller. Damit lässt sich der Fehler schnell und leicht eingrenzen.

Natürlich habe ich die genannte Datei angeschaut, aber in Zeile 56 nichts gefunden, was evtl. ein externes Script/Programm starten möchte.

Nach fast sechs ganzen Tagen, konnte ich endlich die Ursache finden: Der Benutzer „IUSR“ hat auf das Verzeichnis „C:\inetpub\mailroot\Pickup“ kein Schreibzugriff. Den Benutzer unter dem Reiter „Sicherheit“ hinzugefügt. Die Fehlermeldung ist verschwunden und die E-Mail mit dem neuen Passwort kommt beim Benutzer an.

Wie kann man so eine elementar wichtige Anpassung nicht sauber dokumentieren? Sowas gehört definitiv in eine Installationsanleitung!

Abonnieren
Benachrichtige mich bei
0 Comments
Inline Feedbacks
View all comments