phpIPAM unter PHP 7

Bisher wurde phpIPAM unter Ubuntu 14.04 LTS mit PHP 5.6 betrieben. Nachdem inzwischen Ubuntu 16.04.1 LTS verfügbar ist, habe ich mich für ein Upgrade entschlossen. Da es sich dabei um eine virtuelle Maschine (VM) habe ich diese heruntergefahren und einen Snapshot angelegt – sicher ist sicher. Somit ist eine schnelle Wiederherstellung garantiert. Anschließend wird das Release Upgrade durchgeführt und abschließend den Neustart der VM nicht vergessen.

Damit phpIPAM nachdem Upgrade wieder funktioniert müssen folgende Pakete nachinstalliert werden:

apt-get install php7.0-gmp php7.0-mysql libapache2-mod-php7.0 php7.0-ldap php7.0-json php-pear

Zum Schluss noch den Webserver-Dienst neustarten. Danach ist der Aufruf von phpIPAM wieder problemlos möglich.

13.12.2016
Mit dem heutigen Update via Gitub ist nun auch die Erweiterung GD notwendig:

apt-get install php7.0-gd

11.01.2017
Mit dem heutigen Update via Gitub ist nun auch die Erweiterung MBSTRING notwendig:

apt-get install php7.0-mbstring