Das Paket cockpit-pcp kann nicht installiert werden

Wie jeder verantwortungsvolle IT Systemadministrator führe regelmäßige Wartungsarbeiten an meinem Servern. Unter anderem werden aktualisierte Pakete von installierten Programmen auf dem Server installiert. Dabei kam es bei Cockpit Project zu Komplikationen. Die fehlenden Voraussetzungen sorgen dafür, dass eine Installation nicht möglich ist.

apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  cockpit-pcp
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Der Versuch das Paket manuell zu aktualisieren, schlägt ebenfalls fehl.

apt-get install cockpit-pcp
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cockpit-pcp : Depends: cockpit-bridge (>= 186) but 164-1 is to be installed
E: Unable to correct problems, you have held broken packages.

Workaround bzw. Lösung für die Problematik ist die Nutzung von Backports für Ubuntu Bionic.

mount -o remount,exec /tmp
apt-get upgrade -t bionic-backports cockpit

Anschließend prüfen, ob das Cockpit nach wie vor im Browser funktionsfähig ist. Evtl. ist es notwendig den Cache des Browers zu leeren.

Zum Schluss prüfen wie nochmals, ob weitere Aktualisierungen vorliegen.

apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Perfekt. 🙂 Viel Spaß beim Ausprobieren.